What’s Vulnerable › Vulnerabilities
CVE-2019-17059
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-10-11 · updated 2026-06-17
- Weakness: CWE-78
Description
A shell injection vulnerability on the Sophos Cyberoam firewall appliance with CyberoamOS before 10.6.6 MR-6 allows remote attackers to execute arbitrary commands via the Web Admin and SSL VPN consoles.
Affected products
- Sophos Cyberoamos: before 10.6.6; 10.6.6, 10.6.6-maintenance_release1, 10.6.6-maintenance_release2, 10.6.6-maintenance_release3, 10.6.6-maintenance_release4, 10.6.6-maintenance_release5 — fixed in 10.6.6
How to fix
Upgrade to a fixed version: Sophos Cyberoamos 10.6.6. Check the vendor advisory for mitigations.
References
- https://community.sophos.com/kb/en-us/134732
- https://community.sophos.com/products/cyberoamos/
- https://thebestvpn.com/cyberoam-preauth-rce/
- https://community.sophos.com/kb/en-us/134732
- https://community.sophos.com/products/cyberoamos/
- https://thebestvpn.com/cyberoam-preauth-rce/
Get alerted when CVE-2019-17059 or the next vulnerability affects your stack