What’s Vulnerable › Vulnerabilities
CVE-2019-17067
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-01 · updated 2026-06-17
- Weakness: CWE-770
Description
PuTTY before 0.73 on Windows improperly opens port-forwarding listening sockets, which allows attackers to listen on the same port to steal an incoming connection.
Affected products
- PuTTY: before 0.73 — fixed in 0.73
How to fix
Upgrade to a fixed version: PuTTY 0.73. Check the vendor advisory for mitigations.
References
- https://lists.tartarus.org/pipermail/putty-announce/2019/000029.html
- https://security.netapp.com/advisory/ntap-20191127-0003/
- https://lists.tartarus.org/pipermail/putty-announce/2019/000029.html
- https://security.netapp.com/advisory/ntap-20191127-0003/
Get alerted when CVE-2019-17067 or the next vulnerability affects your stack