What’s Vulnerable › Vulnerabilities
CVE-2019-17068
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-01 · updated 2026-06-17
- Weakness: CWE-74
Description
PuTTY before 0.73 mishandles the "bracketed paste mode" protection mechanism, which may allow a session to be affected by malicious clipboard content.
Affected products
- openSUSE Leap: 15.0, 15.1
- PuTTY: before 0.73 — fixed in 0.73
How to fix
Upgrade to a fixed version: PuTTY 0.73. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00020.html
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00021.html
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00030.html
- https://lists.tartarus.org/pipermail/putty-announce/2019/000029.html
- https://security.netapp.com/advisory/ntap-20191127-0003/
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00020.html
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00021.html
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00030.html
- https://lists.tartarus.org/pipermail/putty-announce/2019/000029.html
- https://security.netapp.com/advisory/ntap-20191127-0003/
Get alerted when CVE-2019-17068 or the next vulnerability affects your stack