What’s Vulnerable › Vulnerabilities
CVE-2019-17102: Bitdefender BOX v2 bootstrap update_setup command execution vulnerability (VA-2226)
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-27 · updated 2026-06-17
- Weakness: CWE-413
Description
An exploitable command execution vulnerability exists in the recovery partition of Bitdefender BOX 2, version 2.0.1.91. The API method `/api/update_setup` does not perform firmware signature checks atomically, leading to an exploitable race condition (TOCTTOU) that allows arbitrary execution of system commands. This issue affects: Bitdefender Bitdefender BOX 2 versions prior to 2.1.47.36.
Affected products
- Bitdefender BOX 2: before 2.1.47.36 — fixed in 2.1.47.36
How to fix
Upgrade to a fixed version: Bitdefender BOX 2 2.1.47.36. Check the vendor advisory for mitigations.
References
- https://www.bitdefender.com/support/security-advisories/bitdefender-box-v2-bootstrap-update_setup-command-execution-vulnerability-va-2226
- https://www.bitdefender.com/support/security-advisories/bitdefender-box-v2-bootstrap-update_setup-command-execution-vulnerability-va-2226
Get alerted when CVE-2019-17102 or the next vulnerability affects your stack