What’s Vulnerable › Vulnerabilities
CVE-2019-17113
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-04 · updated 2026-06-17
- Weakness: CWE-120
Description
In libopenmpt before 0.3.19 and 0.4.x before 0.4.9, ModPlug_InstrumentName and ModPlug_SampleName in libopenmpt_modplug.c do not restrict the lengths of libmodplug output-buffer strings in the C API, leading to a buffer overflow.
Affected products
- Openmpt Libopenmpt: before 0.3.19; from 0.4.0 before 0.4.9 — fixed in 0.3.19, 0.4.9
How to fix
Upgrade to a fixed version: Openmpt Libopenmpt 0.3.19, 0.4.9. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00035.html
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00044.html
- https://github.com/OpenMPT/openmpt/commit/927688ddab43c2b203569de79407a899e734fabe
- https://github.com/OpenMPT/openmpt/compare/libopenmpt-0.3.18...libopenmpt-0.3.19
- https://github.com/OpenMPT/openmpt/compare/libopenmpt-0.4.8...libopenmpt-0.4.9
- https://lists.debian.org/debian-lts-announce/2020/08/msg00003.html
- https://source.openmpt.org/browse/openmpt/trunk/OpenMPT/?op=revision&rev=12127&peg=12127
- https://www.debian.org/security/2020/dsa-4729
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00035.html
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00044.html
- https://github.com/OpenMPT/openmpt/commit/927688ddab43c2b203569de79407a899e734fabe
- https://github.com/OpenMPT/openmpt/compare/libopenmpt-0.3.18...libopenmpt-0.3.19
Get alerted when CVE-2019-17113 or the next vulnerability affects your stack