What’s Vulnerable › Vulnerabilities
CVE-2019-17134
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-08 · updated 2026-06-17
- Weakness: CWE-287
Description
Amphora Images in OpenStack Octavia >=0.10.0 <2.1.2, >=3.0.0 <3.2.0, >=4.0.0 <4.1.0 allows anyone with access to the management network to bypass client-certificate based authentication and retrieve information or issue configuration commands via simple HTTP requests to the Agent on port https/9443, because the cmd/agent.py gunicorn cert_reqs option is True but is supposed to be ssl.CERT_REQUIRED.
Affected products
- Canonical Ubuntu Linux: 19.04
- Opendev Octavia: from 0.10.0 before 2.1.2; from 3.0.0 before 3.2.0; from 4.0.0 before 4.1.0 — fixed in 2.1.2, 3.2.0, 4.1.0
How to fix
Upgrade to a fixed version: Opendev Octavia 2.1.2, 3.2.0, 4.1.0. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2019:3743
- https://access.redhat.com/errata/RHSA-2019:3788
- https://access.redhat.com/errata/RHSA-2020:0721
- https://review.opendev.org/686541
- https://review.opendev.org/686543
- https://review.opendev.org/686544
- https://review.opendev.org/686545
- https://review.opendev.org/686546
- https://review.opendev.org/686547
- https://security.openstack.org/ossa/OSSA-2019-005.html
- https://storyboard.openstack.org/#%21/story/2006660
- https://usn.ubuntu.com/4153-1/
Get alerted when CVE-2019-17134 or the next vulnerability affects your stack