What’s Vulnerable › Vulnerabilities
CVE-2019-17138
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-25 · updated 2026-06-17
- Weakness: CWE-125
Description
This vulnerability allows remote attackers to disclose sensitive information on affected installations of Foxit Studio Photo 3.6.6.909. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the conversion from JPEG to EPS. The issue results from the lack of proper validation of user-supplied data, which can result in a read past the end of an allocated structure. An attacker can leverage this in conjunction with other vulnerabilities to execute code in the context of the current process. Was ZDI-CAN-8809.
Affected products
- Foxit Studio Photo: before 3.6.6.916 — fixed in 3.6.6.916
How to fix
Upgrade to a fixed version: Foxit Studio Photo 3.6.6.916. Check the vendor advisory for mitigations.
References
- https://www.foxitsoftware.com/support/security-bulletins.php
- https://www.zerodayinitiative.com/advisories/ZDI-19-908/
- https://www.foxitsoftware.com/support/security-bulletins.php
- https://www.zerodayinitiative.com/advisories/ZDI-19-908/
Get alerted when CVE-2019-17138 or the next vulnerability affects your stack