What’s Vulnerable › Vulnerabilities
CVE-2019-1714: Cisco Adaptive Security Appliance Software and Firepower Threat Defense Software VPN SAML Authentication Bypass Vulnerability
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-05-03 · updated 2026-08-11
- Weakness: CWE-255
Description
A vulnerability in the implementation of Security Assertion Markup Language (SAML) 2.0 Single Sign-On (SSO) for Clientless SSL VPN (WebVPN) and AnyConnect Remote Access VPN in Cisco Adaptive Security Appliance (ASA) Software and Cisco Firepower Threat Defense (FTD) Software could allow an unauthenticated, remote attacker to successfully establish a VPN session to an affected device. The vulnerability is due to improper credential management when using NT LAN Manager (NTLM) or basic authentication. An attacker could exploit this vulnerability by opening a VPN session to an affected device after another VPN user has successfully authenticated to the affected device via SAML SSO. A successful exploit could allow the attacker to connect to secured networks behind the affected device.
Affected products
- Cisco ASA Software: from 9.7 before 9.8.4; from 9.9 before 9.9.2.50; from 9.10 before 9.10.1.17 — fixed in 9.10.1.17, 9.8.4, 9.9.2.50
- Cisco Firepower Threat Defense Software: from 6.2.1 before 6.2.3.12; from 6.3.0 before 6.3.0.3 — fixed in 6.2.3.12, 6.3.0.3
How to fix
Upgrade to a fixed version: Cisco ASA Software 9.10.1.17, 9.8.4, 9.9.2.50; Cisco Firepower Threat Defense Software 6.2.3.12, 6.3.0.3. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/108185
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190501-asaftd-saml-vpn
- http://www.securityfocus.com/bid/108185
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190501-asaftd-saml-vpn
Get alerted when CVE-2019-1714 or the next vulnerability affects your stack