What’s Vulnerable › Vulnerabilities
CVE-2019-17185
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-03-21 · updated 2026-06-17
- Weakness: CWE-662
Description
In FreeRADIUS 3.0.x before 3.0.20, the EAP-pwd module used a global OpenSSL BN_CTX instance to handle all handshakes. This mean multiple threads use the same BN_CTX instance concurrently, resulting in crashes when concurrent EAP-pwd handshakes are initiated. This can be abused by an adversary as a Denial-of-Service (DoS) attack.
Affected products
- freeradius: from 3.0.0 before 3.0.20 — fixed in 3.0.20
- openSUSE Leap: 15.1
How to fix
Upgrade to a fixed version: freeradius 3.0.20. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00039.html
- https://freeradius.org/security/
- https://github.com/FreeRADIUS/freeradius-server/releases/tag/release_3_0_20
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00039.html
- https://freeradius.org/security/
- https://github.com/FreeRADIUS/freeradius-server/releases/tag/release_3_0_20
Get alerted when CVE-2019-17185 or the next vulnerability affects your stack