What’s Vulnerable › Vulnerabilities
CVE-2019-1726: Cisco NX-OS Software CLI Bypass to Internal Service Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-05-15 · updated 2026-06-17
- Weakness: CWE-20
Description
A vulnerability in the CLI of Cisco NX-OS Software could allow an authenticated, local attacker to access internal services that should be restricted on an affected device, such as the NX-API. The vulnerability is due to insufficient validation of arguments passed to a certain CLI command. An attacker could exploit this vulnerability by including malicious input as the argument to the affected command. A successful exploit could allow the attacker to bypass intended restrictions and access internal services of the device. An attacker would need valid device credentials to exploit this vulnerability.
Affected products
- Cisco NX-OS: from 5.2 before 6.2\(25\); from 7.3 before 8.3\(2\); from 7.0\(3\)i7 before 7.0\(3\)i7\(3\); before 6.0\(2\)a8\(11\); from 7.0\(3\) before 7.0\(3\)i7\(3\); before 7.3\(4\)n1\(1\) — fixed in 4.0\(1d\), 6.0\(2\)a8\(11\), 6.2\(22\), 6.2\(25\), 7.0\(3\)i7\(3\), 7.3\(3\)d1\(1\)
How to fix
Upgrade to a fixed version: Cisco NX-OS 4.0\(1d\), 6.0\(2\)a8\(11\), 6.2\(22\), 6.2\(25\). Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/108409
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190515-nxos-cli-bypass
- http://www.securityfocus.com/bid/108409
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190515-nxos-cli-bypass
Get alerted when CVE-2019-1726 or the next vulnerability affects your stack