What’s Vulnerable › Vulnerabilities
CVE-2019-17266
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-06 · updated 2026-06-17
- Weakness: CWE-125
Description
libsoup from versions 2.65.1 until 2.68.1 have a heap-based buffer over-read because soup_ntlm_parse_challenge() in soup-auth-ntlm.c does not properly check an NTLM message's length before proceeding with a memcpy.
Affected products
- Canonical Ubuntu Linux: 18.04, 19.04
- GNOME libsoup: from 2.65.1 before 2.66.4; from 2.67.1 through 2.68.1 — fixed in 2.66.4
How to fix
Upgrade to a fixed version: GNOME libsoup 2.66.4. Check the vendor advisory for mitigations.
References
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=941912
- https://github.com/Kirin-say/Vulnerabilities/blob/master/CVE-2019-17266_POC.md
- https://gitlab.gnome.org/GNOME/libsoup/commit/88b7dff4467f4151afae244ea7d1223753cd05ab
- https://gitlab.gnome.org/GNOME/libsoup/commit/f8a54ac85eec2008c85393f331cdd251af8266ad
- https://gitlab.gnome.org/GNOME/libsoup/issues/173
- https://security-tracker.debian.org/tracker/CVE-2019-17266
- https://usn.ubuntu.com/4152-1/
- https://www.mail-archive.com/debian-bugs-dist%40lists.debian.org/msg1705054.html
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=941912
- https://github.com/Kirin-say/Vulnerabilities/blob/master/CVE-2019-17266_POC.md
- https://gitlab.gnome.org/GNOME/libsoup/commit/88b7dff4467f4151afae244ea7d1223753cd05ab
- https://gitlab.gnome.org/GNOME/libsoup/commit/f8a54ac85eec2008c85393f331cdd251af8266ad
Get alerted when CVE-2019-17266 or the next vulnerability affects your stack