What’s Vulnerable › Vulnerabilities
CVE-2019-1727: Cisco NX-OS Software Python Parser Privilege Escalation Vulnerability
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-05-15 · updated 2026-06-17
- Weakness: CWE-264
Description
A vulnerability in the Python scripting subsystem of Cisco NX-OS Software could allow an authenticated, local attacker to escape the Python parser and issue arbitrary commands to elevate the attacker's privilege level. The vulnerability is due to insufficient sanitization of user-supplied parameters that are passed to certain Python functions in the scripting sandbox of the affected device. An attacker could exploit this vulnerability to escape the scripting sandbox and execute arbitrary commands to elevate the attacker's privilege level. To exploit this vulnerability, the attacker must have local access and be authenticated to the targeted device with administrative or Python execution privileges. These requirements could limit the possibility of a successful exploit.
Affected products
- Cisco NX-OS: from 5.2 before 8.1\(1b\); from 8.2 before 8.3\(1\); from 7.0\(3\)i4 before 7.0\(3\)i4\(8\); from 7.0\(3\)i5 before 7.0\(3\)i7\(3\); from 7.3 before 7.3\(4\)n1\(1\); from 6.2 before 7.3\(3\)d1\(1\) — fixed in 7.0\(3\)i4\(8\), 7.0\(3\)i7\(3\), 7.3\(3\)d1\(1\), 7.3\(4\)n1\(1\), 8.1\(1b\), 8.3\(1\)
How to fix
Upgrade to a fixed version: Cisco NX-OS 7.0\(3\)i4\(8\), 7.0\(3\)i7\(3\), 7.3\(3\)d1\(1\), 7.3\(4\)n1\(1\). Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/108341
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190515-nxos-pyth-escal
- http://www.securityfocus.com/bid/108341
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190515-nxos-pyth-escal
Get alerted when CVE-2019-1727 or the next vulnerability affects your stack