What’s Vulnerable › Vulnerabilities
CVE-2019-1728: Cisco FXOS and NX-OS Software Secure Configuration Bypass Vulnerability
- Severity: medium (CVSS 6.7 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-05-15 · updated 2026-06-17
- Weakness: CWE-347
Description
A vulnerability in the Secure Configuration Validation functionality of Cisco FXOS Software and Cisco NX-OS Software could allow an authenticated, local attacker to run arbitrary commands at system boot time with the privileges of root. The vulnerability is due to a lack of proper validation of system files when the persistent configuration information is read from the file system. An attacker could exploit this vulnerability by authenticating to the device and overwriting the persistent configuration storage with malicious executable files. An exploit could allow the attacker to run arbitrary commands at system startup and those commands will run as the root user. The attacker must have valid administrative credentials for the device.
Affected products
- Cisco NX-OS: from 8.1 before 8.1\(1b\); from 8.2 before 8.3\(1\); from 7.0\(3\)i7 before 7.0\(3\)i7\(3\); from 6.0\(2\)a8 before 6.0\(2\)a8\(11\); from 7.0\(3\) before 7.0\(3\)i7\(3\); from 7.3 before 7.3\(4\)n1\(1\) — fixed in 2.4.1.101, 4.0\(1a\), 6.0\(2\)a8\(11\), 6.2\(22\), 7.0\(3\)i7\(3\), 7.3\(3\)d1\(1\)
How to fix
Upgrade to a fixed version: Cisco NX-OS 2.4.1.101, 4.0\(1a\), 6.0\(2\)a8\(11\), 6.2\(22\). Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/108391
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190515-nxos-conf-bypass
- http://www.securityfocus.com/bid/108391
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190515-nxos-conf-bypass
Get alerted when CVE-2019-1728 or the next vulnerability affects your stack