What’s Vulnerable › Vulnerabilities
CVE-2019-1733: Cisco NX-OS Software NX-API Sandbox Cross-Site Scripting Vulnerability
- Severity: medium (CVSS 5.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-05-15 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability in the NX API (NX-API) Sandbox interface for Cisco NX-OS Software could allow an authenticated, remote attacker to conduct a cross-site scripting (XSS) attack against a user of the NX-API Sandbox interface of an affected device. The vulnerability is due to insufficient validation of user-supplied input by the NX-API Sandbox interface. An attacker could exploit this vulnerability by persuading a user of the NX-API Sandbox interface to click a crafted link. A successful exploit could allow the attacker to execute arbitrary script code in the context of the affected NX-API Sandbox interface.
Affected products
- Cisco NX-OS: from 7.0\(3\)i7 before 7.0\(3\)i7\(4\) — fixed in 7.0\(3\)i7\(4\)
How to fix
Upgrade to a fixed version: Cisco NX-OS 7.0\(3\)i7\(4\). Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/108348
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190515-nxos-nxapi-xss
- http://www.securityfocus.com/bid/108348
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190515-nxos-nxapi-xss
Get alerted when CVE-2019-1733 or the next vulnerability affects your stack