What’s Vulnerable › Vulnerabilities
CVE-2019-17383
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-09 · updated 2026-06-17
- Weakness: CWE-276
Description
The netaddr gem before 2.0.4 for Ruby has misconfigured file permissions, such that a gem install may result in 0777 permissions in the target filesystem.
Affected products
- Netaddr Project Netaddr: from 1.5.0 before 1.5.3; from 2.0 before 2.0.4 — fixed in 1.5.3, 2.0.4
How to fix
Upgrade to a fixed version: Netaddr Project Netaddr 1.5.3, 2.0.4. Check the vendor advisory for mitigations.
References
- https://github.com/dspinhirne/netaddr-rb/commit/3aac46c00a36e71905eaa619cb94d45bff6e3b51
- https://rubygems.org/gems/netaddr/versions
- https://github.com/dspinhirne/netaddr-rb/commit/3aac46c00a36e71905eaa619cb94d45bff6e3b51
- https://rubygems.org/gems/netaddr/versions
Get alerted when CVE-2019-17383 or the next vulnerability affects your stack