What’s Vulnerable › Vulnerabilities
CVE-2019-17386
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-10 · updated 2026-06-17
- Weakness: CWE-352
Description
The animate-it plugin before 2.3.6 for WordPress has CSRF in edsanimate.php.
Affected products
- eleopard Animate It!: before 2.3.6 — fixed in 2.3.6
How to fix
Upgrade to a fixed version: eleopard Animate It! 2.3.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?old_path=%2Fanimate-it%2Ftags%2F2.3.6%2Fedsanimate.php&old=2129363&new_path=%2Fanimate-it%2Ftags%2F2.3.5%2Fedsanimate.php
- https://wordpress.org/plugins/animate-it/#developers
- https://wpvulndb.com/vulnerabilities/9900
- https://www.pluginvulnerabilities.com/2019/07/29/vulnerability-details-cross-site-request-forgery-csrf-cross-site-scripting-xss-in-animate-it/
- https://plugins.trac.wordpress.org/changeset?old_path=%2Fanimate-it%2Ftags%2F2.3.6%2Fedsanimate.php&old=2129363&new_path=%2Fanimate-it%2Ftags%2F2.3.5%2Fedsanimate.php
- https://wordpress.org/plugins/animate-it/#developers
- https://wpvulndb.com/vulnerabilities/9900
- https://www.pluginvulnerabilities.com/2019/07/29/vulnerability-details-cross-site-request-forgery-csrf-cross-site-scripting-xss-in-animate-it/
Get alerted when CVE-2019-17386 or the next vulnerability affects your stack