What’s Vulnerable › Vulnerabilities
CVE-2019-17409
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-21 · updated 2026-06-17
- Weakness: CWE-79
Description
Reflected XSS exists in interface/forms/eye_mag/view.php in OpenEMR 5.x before 5.0.2.1 ia the id parameter.
Affected products
- openemr: from 5.0.1 before 5.0.2.1 — fixed in 5.0.2.1
How to fix
Upgrade to a fixed version: openemr 5.0.2.1. Check the vendor advisory for mitigations.
References
- https://github.com/lodestone-security/CVEs/blob/master/CVE-2019-17409/README.md
- https://github.com/openemr/openemr/pull/2712/files
- https://github.com/lodestone-security/CVEs/blob/master/CVE-2019-17409/README.md
- https://github.com/openemr/openemr/pull/2712/files
Get alerted when CVE-2019-17409 or the next vulnerability affects your stack