What’s Vulnerable › Vulnerabilities
CVE-2019-17513
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-18 · updated 2026-06-17
- Weakness: CWE-74
Description
An issue was discovered in Ratpack before 1.7.5. Due to a misuse of the Netty library class DefaultHttpHeaders, there is no validation that headers lack HTTP control characters. Thus, if untrusted data is used to construct HTTP headers with Ratpack, HTTP Response Splitting can occur.
Affected products
- ratpack: before 1.7.5 — fixed in 1.7.5
How to fix
Upgrade to a fixed version: ratpack 1.7.5. Check the vendor advisory for mitigations.
References
- https://github.com/ratpack/ratpack/commit/c560a8d10cb8bdd7a526c1ca2e67c8f224ca23ae
- https://github.com/ratpack/ratpack/commit/efb910d38a96494256f36675ef0e5061097dd77d
- https://github.com/ratpack/ratpack/releases/tag/v1.7.5
- https://github.com/ratpack/ratpack/security/advisories/GHSA-mvqp-q37c-wf9j
- https://ratpack.io/versions/1.7.5
- https://github.com/ratpack/ratpack/commit/c560a8d10cb8bdd7a526c1ca2e67c8f224ca23ae
- https://github.com/ratpack/ratpack/commit/efb910d38a96494256f36675ef0e5061097dd77d
- https://github.com/ratpack/ratpack/releases/tag/v1.7.5
- https://github.com/ratpack/ratpack/security/advisories/GHSA-mvqp-q37c-wf9j
- https://ratpack.io/versions/1.7.5
Get alerted when CVE-2019-17513 or the next vulnerability affects your stack