What’s Vulnerable › Vulnerabilities
CVE-2019-17540
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-14 · updated 2026-06-17
- Weakness: CWE-787
Description
ImageMagick before 7.0.8-54 has a heap-based buffer overflow in ReadPSInfo in coders/ps.c.
Affected products
- Debian Linux: 9.0, 10.0
- ImageMagick: from 6.9.10-54 before 6.9.10-55; from 7.0.0-0 before 7.0.8-54 — fixed in 6.9.10-55, 7.0.8-54
How to fix
Upgrade to a fixed version: ImageMagick 6.9.10-55, 7.0.8-54. Check the vendor advisory for mitigations.
References
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=15826
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=942578
- https://github.com/ImageMagick/ImageMagick/compare/7.0.8-53...7.0.8-54
- https://github.com/ImageMagick/ImageMagick/compare/master%40%7B2019-07-15%7D...master%40%7B2019-07-17%7D
- https://security-tracker.debian.org/tracker/CVE-2019-17540
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=15826
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=942578
- https://github.com/ImageMagick/ImageMagick/compare/7.0.8-53...7.0.8-54
- https://github.com/ImageMagick/ImageMagick/compare/master%40%7B2019-07-15%7D...master%40%7B2019-07-17%7D
- https://security-tracker.debian.org/tracker/CVE-2019-17540
Get alerted when CVE-2019-17540 or the next vulnerability affects your stack