What’s Vulnerable › Vulnerabilities
CVE-2019-17542
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-14 · updated 2026-06-17
- Weakness: CWE-787
Description
FFmpeg before 4.2 has a heap-based buffer overflow in vqa_decode_chunk because of an out-of-array access in vqa_decode_init in libavcodec/vqavideo.c.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04, 20.04
- Debian Linux: 8.0, 9.0, 10.0
- FFmpeg: before 2.8.16; from 3.2 before 3.2.15; from 3.4 before 3.4.7; from 4.0 before 4.0.5; from 4.1 before 4.1.5 — fixed in 2.8.16, 3.2.15, 3.4.7, 4.0.5, 4.1.5
How to fix
Upgrade to a fixed version: FFmpeg 2.8.16, 3.2.15, 3.4.7, 4.0.5. Check the vendor advisory for mitigations.
References
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=15919
- https://github.com/FFmpeg/FFmpeg/commit/02f909dc24b1f05cfbba75077c7707b905e63cd2
- https://lists.debian.org/debian-lts-announce/2019/12/msg00003.html
- https://lists.debian.org/debian-lts-announce/2020/07/msg00022.html
- https://security.gentoo.org/glsa/202003-65
- https://usn.ubuntu.com/4431-1/
- https://www.debian.org/security/2020/dsa-4722
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=15919
- https://github.com/FFmpeg/FFmpeg/commit/02f909dc24b1f05cfbba75077c7707b905e63cd2
- https://lists.debian.org/debian-lts-announce/2019/12/msg00003.html
- https://lists.debian.org/debian-lts-announce/2020/07/msg00022.html
- https://security.gentoo.org/glsa/202003-65
Get alerted when CVE-2019-17542 or the next vulnerability affects your stack