What’s Vulnerable › Vulnerabilities
CVE-2019-17544
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-14 · updated 2026-06-17
- Weakness: CWE-125
Description
libaspell.a in GNU Aspell before 0.60.8 has a stack-based buffer over-read in acommon::unescape in common/getdata.cpp via an isolated \ character.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 18.04, 19.04
- GNU Aspell: before 0.60.8 — fixed in 0.60.8
How to fix
Upgrade to a fixed version: GNU Aspell 0.60.8. Check the vendor advisory for mitigations.
References
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=16109
- https://github.com/GNUAspell/aspell/commit/80fa26c74279fced8d778351cff19d1d8f44fe4e
- https://github.com/GNUAspell/aspell/compare/rel-0.60.7...rel-0.60.8
- https://lists.debian.org/debian-lts-announce/2019/10/msg00027.html
- https://lists.debian.org/debian-lts-announce/2021/07/msg00021.html
- https://usn.ubuntu.com/4155-1/
- https://usn.ubuntu.com/4155-2/
- https://www.debian.org/security/2021/dsa-4948
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=16109
- https://github.com/GNUAspell/aspell/commit/80fa26c74279fced8d778351cff19d1d8f44fe4e
- https://github.com/GNUAspell/aspell/compare/rel-0.60.7...rel-0.60.8
- https://lists.debian.org/debian-lts-announce/2019/10/msg00027.html
Get alerted when CVE-2019-17544 or the next vulnerability affects your stack