What’s Vulnerable › Vulnerabilities
CVE-2019-17550
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The Blog2Social plugin before 5.9.0 for WordPress is affected by: Cross Site Scripting (XSS). The impact is: Allows an attacker to execute arbitrary HTML and JavaScript code via the b2s_id parameter. The component is: views/b2s/post.calendar.php. The attack vector is: When the Administrator is logged in, a reflected XSS may execute upon a click on a malicious URL.
Affected products
- pr-gateway Blog2Social: Social Media Auto Post & Scheduler: before 5.9.0 — fixed in 5.9.0
How to fix
Upgrade to a fixed version: pr-gateway Blog2Social: Social Media Auto Post & Scheduler 5.9.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/2186043
- https://plugins.trac.wordpress.org/log/blog2social/
- https://wordpress.org/plugins/blog2social/#developers
- https://wpvulndb.com/vulnerabilities/9948
- https://plugins.trac.wordpress.org/changeset/2186043
- https://plugins.trac.wordpress.org/log/blog2social/
- https://wordpress.org/plugins/blog2social/#developers
- https://wpvulndb.com/vulnerabilities/9948
Get alerted when CVE-2019-17550 or the next vulnerability affects your stack