What’s Vulnerable › Vulnerabilities
CVE-2019-17557
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-05-04 · updated 2026-06-17
- Weakness: CWE-79
Description
It was found that the Apache Syncope EndUser UI login page prio to 2.0.15 and 2.1.6 reflects the successMessage parameters. By this mean, a user accessing the Enduser UI could execute javascript code from URL query string.
Affected products
- Apache Software Foundation Apache Syncope: from 2.0.0 before 2.0.15; from 2.1.0 before 2.1.6 — fixed in 2.0.15, 2.1.6
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Syncope 2.0.15, 2.1.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-17557 or the next vulnerability affects your stack