What’s Vulnerable › Vulnerabilities
CVE-2019-17574
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 9.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-10-14 · updated 2026-06-17
- Weakness: CWE-639
Description
An issue was discovered in the Popup Maker plugin before 1.8.13 for WordPress. An unauthenticated attacker can partially control the arguments of the do_action function to invoke certain popmake_ or pum_ methods, as demonstrated by controlling content and delivery of popmake-system-info.txt (aka the "support debug text file").
Affected products
- danieliser Popup Maker – Boost Sales, Conversions, Optins, Subscribers with the Ultimate WP Popup Builder: before 1.8.13 — fixed in 1.8.13
How to fix
Upgrade to a fixed version: danieliser Popup Maker – Boost Sales, Conversions, Optins, Subscribers with the Ultimate WP Popup Builder 1.8.13. Check the vendor advisory for mitigations.
References
- http://blog.redyops.com/wordpress-plugin-popup-maker/
- https://github.com/PopupMaker/Popup-Maker/blob/master/CHANGELOG.md
- https://wpvulndb.com/vulnerabilities/9907
- http://blog.redyops.com/wordpress-plugin-popup-maker/
- https://github.com/PopupMaker/Popup-Maker/blob/master/CHANGELOG.md
- https://wpvulndb.com/vulnerabilities/9907
Get alerted when CVE-2019-17574 or the next vulnerability affects your stack