What’s Vulnerable › Vulnerabilities
CVE-2019-17592
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-14 · updated 2026-06-17
- Weakness: CWE-400
Description
The csv-parse module before 4.4.6 for Node.js is vulnerable to Regular Expression Denial of Service. The __isInt() function contains a malformed regular expression that processes large crafted input very slowly. This is triggered when using the cast option.
Affected products
- Csv-Parse Project Csv-Parse: before 4.4.6 — fixed in 4.4.6
- Fedoraproject Fedora: 31
How to fix
Upgrade to a fixed version: Csv-Parse Project Csv-Parse 4.4.6. Check the vendor advisory for mitigations.
References
- https://github.com/adaltas/node-csv-parse/commit/b9d35940c6815cdf1dfd6b21857a1f6d0fd51e4a
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/Z36UKPO5F3PQ3Q2POMF5LEKXWAH5RUFP/
- https://security.netapp.com/advisory/ntap-20191127-0002/
- https://www.npmjs.com/advisories/1171
- https://github.com/adaltas/node-csv-parse/commit/b9d35940c6815cdf1dfd6b21857a1f6d0fd51e4a
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/Z36UKPO5F3PQ3Q2POMF5LEKXWAH5RUFP/
- https://security.netapp.com/advisory/ntap-20191127-0002/
- https://www.npmjs.com/advisories/1171
Get alerted when CVE-2019-17592 or the next vulnerability affects your stack