What’s Vulnerable › Vulnerabilities

CVE-2019-17596

Description

Go before 1.12.11 and 1.3.x before 1.13.2 can panic upon an attempt to process network traffic containing an invalid DSA public key. There are several attack scenarios, such as traffic from a client to a server that verifies client certificates.

Affected products

How to fix

Upgrade to a fixed version: Go 1.12.11, 1.13.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-17596 or the next vulnerability affects your stack