What’s Vulnerable › Vulnerabilities
CVE-2019-17599
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-12-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The quiz-master-next (aka Quiz And Survey Master) plugin before 6.3.5 for WordPress is affected by: Cross Site Scripting (XSS). The impact is: Allows an attacker to execute arbitrary HTML and JavaScript code via the from or till parameter (and/or the quiz_id parameter). The component is: admin/quiz-options-page.php. The attack vector is: When the Administrator is logged in, a reflected XSS may execute upon a click on a malicious URL.
Affected products
- ExpressTech Quiz And Survey Master: before 6.3.5 — fixed in 6.3.5
How to fix
Upgrade to a fixed version: ExpressTech Quiz And Survey Master 6.3.5. Check the vendor advisory for mitigations.
References
- https://github.com/QuizandSurveyMaster/quiz_master_next/issues/795
- https://github.com/QuizandSurveyMaster/quiz_master_next/pull/796
- https://wordpress.org/plugins/quiz-master-next/#developers
- https://wpvulndb.com/vulnerabilities/9977
- https://github.com/QuizandSurveyMaster/quiz_master_next/issues/795
- https://github.com/QuizandSurveyMaster/quiz_master_next/pull/796
- https://wordpress.org/plugins/quiz-master-next/#developers
- https://wpvulndb.com/vulnerabilities/9977
Get alerted when CVE-2019-17599 or the next vulnerability affects your stack