What’s Vulnerable › Vulnerabilities

CVE-2019-17656

Description

A Stack-based Buffer Overflow vulnerability in the HTTPD daemon of FortiOS 6.0.10 and below, 6.2.2 and below and FortiProxy 1.0.x, 1.1.x, 1.2.9 and below, 2.0.0 and below may allow an authenticated remote attacker to crash the service by sending a malformed PUT request to the server. Fortinet is not aware of any successful exploitation of this vulnerability that would lead to code execution.

Affected products

How to fix

Upgrade to a fixed version: Fortinet FortiProxy 1.2.10, 2.0.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-17656 or the next vulnerability affects your stack