What’s Vulnerable › Vulnerabilities
CVE-2019-17666
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-17 · updated 2026-06-17
- Weakness: CWE-120
Description
rtl_p2p_noa_ie in drivers/net/wireless/realtek/rtlwifi/ps.c in the Linux kernel through 5.3.6 lacks a certain upper-bound check, leading to a buffer overflow.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 19.04, 19.10
- Debian Linux: 8.0
- Linux kernel: before 3.16.77; from 3.17 before 4.4.199; from 4.5 before 4.9.199; from 4.10 before 4.14.152; from 4.15 before 4.19.82; from 4.20 before 5.2 — fixed in 3.16.77, 4.14.152, 4.19.82, 4.4.199, 4.9.199, 5.2
How to fix
Upgrade to a fixed version: Linux kernel 3.16.77, 4.14.152, 4.19.82, 4.4.199. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00064.html
- http://lists.opensuse.org/opensuse-security-announce/2019-11/msg00010.html
- https://access.redhat.com/errata/RHSA-2020:0328
- https://access.redhat.com/errata/RHSA-2020:0339
- https://access.redhat.com/errata/RHSA-2020:0543
- https://access.redhat.com/errata/RHSA-2020:0661
- https://access.redhat.com/errata/RHSA-2020:0740
- https://arstechnica.com/information-technology/2019/10/unpatched-linux-flaw-may-let-attackers-crash-or-compromise-nearby-devices/
- https://lists.debian.org/debian-lts-announce/2020/01/msg00013.html
- https://lists.debian.org/debian-lts-announce/2020/03/msg00001.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/TRBP4O6D2SQ2NHCRHTJONGCZLWOIV5MN/
- https://lkml.org/lkml/2019/10/16/1226
Get alerted when CVE-2019-17666 or the next vulnerability affects your stack