What’s Vulnerable › Vulnerabilities
CVE-2019-17670
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-17 · updated 2026-06-17
- Weakness: CWE-918
Description
WordPress before 5.2.4 has a Server Side Request Forgery (SSRF) vulnerability because Windows paths are mishandled during certain validation of relative URLs.
Affected products
- Debian Linux: 8.0, 9.0, 10.0
- WordPress: before 5.2.4 — fixed in 5.2.4
How to fix
Upgrade to a fixed version: WordPress 5.2.4. Check the vendor advisory for mitigations.
References
- https://blog.wpscan.org/wordpress/security/release/2019/10/15/wordpress-524-security-release-breakdown.html
- https://core.trac.wordpress.org/changeset/46472
- https://github.com/WordPress/WordPress/commit/9db44754b9e4044690a6c32fd74b9d5fe26b07b2
- https://lists.debian.org/debian-lts-announce/2019/11/msg00000.html
- https://lists.debian.org/debian-lts-announce/2020/09/msg00011.html
- https://lists.debian.org/debian-lts-announce/2022/10/msg00010.html
- https://wordpress.org/news/2019/10/wordpress-5-2-4-security-release/
- https://wpvulndb.com/vulnerabilities/9912
- https://blog.wpscan.org/wordpress/security/release/2019/10/15/wordpress-524-security-release-breakdown.html
- https://core.trac.wordpress.org/changeset/46472
- https://github.com/WordPress/WordPress/commit/9db44754b9e4044690a6c32fd74b9d5fe26b07b2
- https://lists.debian.org/debian-lts-announce/2019/11/msg00000.html
Get alerted when CVE-2019-17670 or the next vulnerability affects your stack