What’s Vulnerable › Vulnerabilities
CVE-2019-17671
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 36.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-10-17 · updated 2026-06-17
- Weakness: CWE-200
Description
In WordPress before 5.2.4, unauthenticated viewing of certain content is possible because the static query property is mishandled.
Affected products
- Debian Linux: 8.0, 9.0, 10.0
- WordPress: before 5.2.4 — fixed in 5.2.4
How to fix
Upgrade to a fixed version: WordPress 5.2.4. Check the vendor advisory for mitigations.
References
- https://blog.wpscan.org/wordpress/security/release/2019/10/15/wordpress-524-security-release-breakdown.html
- https://core.trac.wordpress.org/changeset/46474
- https://github.com/WordPress/WordPress/commit/f82ed753cf00329a5e41f2cb6dc521085136f308
- https://lists.debian.org/debian-lts-announce/2019/11/msg00000.html
- https://seclists.org/bugtraq/2020/Jan/8
- https://wordpress.org/news/2019/10/wordpress-5-2-4-security-release/
- https://wpvulndb.com/vulnerabilities/9909
- https://www.debian.org/security/2020/dsa-4599
- https://www.debian.org/security/2020/dsa-4677
- https://blog.wpscan.org/wordpress/security/release/2019/10/15/wordpress-524-security-release-breakdown.html
- https://core.trac.wordpress.org/changeset/46474
- https://github.com/WordPress/WordPress/commit/f82ed753cf00329a5e41f2cb6dc521085136f308
Get alerted when CVE-2019-17671 or the next vulnerability affects your stack