What’s Vulnerable › Vulnerabilities
CVE-2019-17673
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-17 · updated 2026-06-17
Description
WordPress before 5.2.4 is vulnerable to poisoning of the cache of JSON GET requests because certain requests lack a Vary: Origin header.
Affected products
- Debian Linux: 9.0, 10.0
- WordPress: before 5.2.4 — fixed in 5.2.4
How to fix
Upgrade to a fixed version: WordPress 5.2.4. Check the vendor advisory for mitigations.
References
- https://blog.wpscan.org/wordpress/security/release/2019/10/15/wordpress-524-security-release-breakdown.html
- https://core.trac.wordpress.org/changeset/46478
- https://github.com/WordPress/WordPress/commit/b224c251adfa16a5f84074a3c0886270c9df38de
- https://seclists.org/bugtraq/2020/Jan/8
- https://wordpress.org/news/2019/10/wordpress-5-2-4-security-release/
- https://wpvulndb.com/vulnerabilities/9911
- https://www.debian.org/security/2020/dsa-4599
- https://www.debian.org/security/2020/dsa-4677
- https://blog.wpscan.org/wordpress/security/release/2019/10/15/wordpress-524-security-release-breakdown.html
- https://core.trac.wordpress.org/changeset/46478
- https://github.com/WordPress/WordPress/commit/b224c251adfa16a5f84074a3c0886270c9df38de
- https://seclists.org/bugtraq/2020/Jan/8
Get alerted when CVE-2019-17673 or the next vulnerability affects your stack