What’s Vulnerable › Vulnerabilities
CVE-2019-1783: Cisco NX-OS Software Command Injection Vulnerability
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-05-15 · updated 2026-06-17
- Weakness: CWE-77
Description
A vulnerability in the CLI of Cisco NX-OS Software could allow an authenticated, local attacker with administrator credentials to execute arbitrary commands on the underlying Linux operating system with the privilege level of root. The vulnerability is due to insufficient validation of arguments passed to a specific CLI command on the affected device. An attacker could exploit this vulnerability by including malicious input as the argument of an affected command. A successful exploit could allow the attacker to execute arbitrary commands on the underlying Linux operating system with elevated privileges. An attacker would need valid administrator credentials to exploit this vulnerability.
Affected products
- Cisco NX-OS: before 7.3\(4\)n1\(1\); from 7.2 before 7.3\(3\)d1\(1\); from 8.0 before 8.3\(1\) — fixed in 7.3\(3\)d1\(1\), 7.3\(4\)n1\(1\), 8.3\(1\)
How to fix
Upgrade to a fixed version: Cisco NX-OS 7.3\(3\)d1\(1\), 7.3\(4\)n1\(1\), 8.3\(1\). Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/108370
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190515-nxos-cmdinj-1783
- http://www.securityfocus.com/bid/108370
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190515-nxos-cmdinj-1783
Get alerted when CVE-2019-1783 or the next vulnerability affects your stack