What’s Vulnerable › Vulnerabilities
CVE-2019-1791: Cisco NX-OS Software Command Injection Vulnerability
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-05-15 · updated 2026-06-17
- Weakness: CWE-77
Description
A vulnerability in the CLI of Cisco NX-OS Software could allow an authenticated, local attacker with administrator credentials to execute arbitrary commands with elevated privileges on the underlying operating system of an affected device. The vulnerability is due to insufficient validation of arguments passed to certain CLI commands. An attacker could exploit this vulnerability by including malicious input as the argument of an affected command. A successful exploit could allow the attacker to execute arbitrary commands on the underlying operating system with elevated privileges. An attacker would need valid administrator credentials to exploit this vulnerability.
Affected products
- Cisco NX-OS: from 5.2 before 6.2\(25\); from 7.3 before 8.2\(3\); from 8.3 before 8.3\(1\); before 7.0\(3\)i4\(9\); from 7.0\(3\)i7 before 7.3\(3\)i7\(6\); before 6.0\(2\)a8\(11\) — fixed in 6.0\(2\)a8\(11\), 6.2\(22\), 6.2\(25\), 7.0\(3\)f3\(5\), 7.0\(3\)i4\(9\), 7.3\(3\)d1\(1\)
How to fix
Upgrade to a fixed version: Cisco NX-OS 6.0\(2\)a8\(11\), 6.2\(22\), 6.2\(25\), 7.0\(3\)f3\(5\). Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/108390
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190515-nxos-cmdinj-1791
- http://www.securityfocus.com/bid/108390
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190515-nxos-cmdinj-1791
Get alerted when CVE-2019-1791 or the next vulnerability affects your stack