What’s Vulnerable › Vulnerabilities
CVE-2019-1795: Cisco FXOS and NX-OS Software Command Injection Vulnerability
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-05-15 · updated 2026-06-17
- Weakness: CWE-77
Description
A vulnerability in the CLI of Cisco FXOS Software and Cisco NX-OS Software could allow an authenticated, local attacker to execute arbitrary commands on the underlying Linux operating system with the privilege level of root. The vulnerability is due to insufficient validation of arguments passed to a specific CLI command on the affected device. An attacker could exploit this vulnerability by including malicious input as the argument of an affected command. A successful exploit could allow the attacker to execute arbitrary commands on the underlying Linux operating system with elevated privileges. An attacker would need valid administrator credentials to exploit this vulnerability.
Affected products
- Cisco Firepower Extensible Operating System (FXOS): before 2.0.1.201; from 2.1 before 2.2.2.54; from 2.3 before 2.3.1.73; from 2.4 before 2.4.1.101 — fixed in 2.0.1.201, 2.2.2.54, 2.3.1.73, 2.4.1.101
- Cisco NX-OS: before 8.2\(3\); from 8.3 before 8.3\(1\); before 7.0\(3\)i4\(8\); from 7.0\(3\)i7 before 7.3\(3\)i7\(3\); before 6.0\(2\)a8\(11\); from 7.0\(3\)i4 before 7.0\(3\)i4\(8\) — fixed in 3.2\(3a\), 4.0\(1a\), 5.2, 5.2\(1\)sv3\(4.1\), 6.0\(2\)a8\(11\), 6.2\(22\)
How to fix
Upgrade to a fixed version: Cisco Firepower Extensible Operating System (FXOS) 2.0.1.201, 2.2.2.54, 2.3.1.73, 2.4.1.101; Cisco NX-OS 3.2\(3a\), 4.0\(1a\), 5.2, 5.2\(1\)sv3\(4.1\). Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/108479
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190515-nxos-cmdinj-1795
- http://www.securityfocus.com/bid/108479
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190515-nxos-cmdinj-1795
Get alerted when CVE-2019-1795 or the next vulnerability affects your stack