What’s Vulnerable › Vulnerabilities
CVE-2019-1797: Cisco Wireless LAN Controller Software Cross-Site Request Forgery Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-18 · updated 2026-06-17
- Weakness: CWE-352
Description
A vulnerability in the web-based management interface of Cisco Wireless LAN Controller (WLC) Software could allow an unauthenticated, remote attacker to conduct a cross-site request forgery (CSRF) attack and perform arbitrary actions on the device with the privileges of the user, including modifying the device configuration. The vulnerability is due to insufficient CSRF protections for the web-based management interface of an affected device. An attacker could exploit this vulnerability by persuading an interface user to follow a crafted link. A successful exploit could allow the attacker to perform arbitrary actions on the device with the privileges of the user. Software versions prior to 8.3.150.0, 8.5.135.0, and 8.8.100.0 are affected.
Affected products
- Cisco Wireless LAN Controller (WLC): before 8.3.150.0; from 8.5.131.0 before 8.5.150.0; from 8.7.106.0 before 8.8.100.0 — fixed in 8.3.150.0, 8.5.150.0, 8.8.100.0
How to fix
Upgrade to a fixed version: Cisco Wireless LAN Controller (WLC) 8.3.150.0, 8.5.150.0, 8.8.100.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/107998
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190417-wlc-csrf
- http://www.securityfocus.com/bid/107998
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190417-wlc-csrf
Get alerted when CVE-2019-1797 or the next vulnerability affects your stack