What’s Vulnerable › Vulnerabilities
CVE-2019-1799: Cisco Wireless LAN Controller Software IAPP Message Handling Denial of Service Vulnerabilities
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-18 · updated 2026-06-17
- Weakness: CWE-399
Description
A vulnerability in the handling of Inter-Access Point Protocol (IAPP) messages by Cisco Wireless LAN Controller (WLC) Software could allow an unauthenticated, adjacent attacker to cause a denial of service (DoS) condition. The vulnerability exist because the software improperly validates input on fields within IAPP messages. An attacker could exploit the vulnerability by sending malicious IAPP messages to an affected device. A successful exploit could allow the attacker to cause the Cisco WLC Software to reload, resulting in a DoS condition. Software versions prior to 8.2.170.0, 8.5.150.0, and 8.8.100.0 are affected.
Affected products
- Cisco Wireless Lan Controller: before 8.2.170.0 — fixed in 8.2.170.0
- Cisco Wireless LAN Controller (WLC): from 8.3.143.0 before 8.3.150.0; from 8.5.103.0 before 8.5.131.0; from 8.6.101.0 before 8.8.100.0 — fixed in 8.3.150.0, 8.5.131.0, 8.8.100.0
How to fix
Upgrade to a fixed version: Cisco Wireless Lan Controller 8.2.170.0; Cisco Wireless LAN Controller (WLC) 8.3.150.0, 8.5.131.0, 8.8.100.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/108008
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190417-wlc-iapp
- http://www.securityfocus.com/bid/108008
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190417-wlc-iapp
Get alerted when CVE-2019-1799 or the next vulnerability affects your stack