What’s Vulnerable › Vulnerabilities
CVE-2019-1806: Cisco Small Business Series Switches Simple Network Management Protocol Denial of Service Vulnerability
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-05-15 · updated 2026-06-17
- Weakness: CWE-20
Description
A vulnerability in the Simple Network Management Protocol (SNMP) input packet processor of Cisco Small Business Sx200, Sx300, Sx500, ESW2 Series Managed Switches and Small Business Sx250, Sx350, Sx550 Series Switches could allow an authenticated, remote attacker to cause the SNMP application of an affected device to cease processing traffic, resulting in the CPU utilization reaching one hundred percent. Manual intervention may be required before a device resumes normal operations. The vulnerability is due to improper validation of SNMP protocol data units (PDUs) in SNMP packets. An attacker could exploit this vulnerability by sending a malicious SNMP packet to an affected device. A successful exploit could allow the attacker to cause the device to cease forwarding traffic, which could result in a denial of service (DoS) condition. Cisco has released firmware updates that address this vulnerability.
Affected products
- Cisco Esw2-350G52Dc Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Esw2-550X48Dc Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf200-24 Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf200-24P Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf200-48 Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf200-48P Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf250-24 Firmware: before 2.5.0.78 — fixed in 2.5.0.78
- Cisco Sf250-24P Firmware: before 2.5.0.78 — fixed in 2.5.0.78
- Cisco Sf250-48 Firmware: before 2.5.0.78 — fixed in 2.5.0.78
- Cisco Sf250-48Hp Firmware: before 2.5.0.78 — fixed in 2.5.0.78
- Cisco Sf300-08 Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf300-24 Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf300-24Mp Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf300-24P Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf300-24Pp Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf300-48 Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf300-48P Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf300-48Pp Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf302-08 Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf302-08Mp Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf302-08Mpp Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf302-08P Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf302-08Pp Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf350-48 Firmware: before 2.5.0.78 — fixed in 2.5.0.78
- Cisco Sf350-48Mp Firmware: before 2.5.0.78 — fixed in 2.5.0.78
- Cisco Sf350-48P Firmware: before 2.5.0.78 — fixed in 2.5.0.78
- Cisco Sf500-24 Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf500-24Mp Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf500-24P Firmware: before 1.4.10.6 — fixed in 1.4.10.6
- Cisco Sf500-48 Firmware: before 1.4.10.6 — fixed in 1.4.10.6
How to fix
Upgrade to a fixed version: Cisco Esw2-350G52Dc Firmware 1.4.10.6; Cisco Esw2-550X48Dc Firmware 1.4.10.6; Cisco Sf200-24 Firmware 1.4.10.6; Cisco Sf200-24P Firmware 1.4.10.6; Cisco Sf200-48 Firmware 1.4.10.6; Cisco Sf200-48P Firmware 1.4.10.6; Cisco Sf250-24 Firmware 2.5.0.78; Cisco Sf250-24P Firmware 2.5.0.78; Cisco Sf250-48 Firmware 2.5.0.78; Cisco Sf250-48Hp Firmware 2.5.0.78; Cisco Sf300-08 Firmware 1.4.10.6; Cisco Sf300-24 Firmware 1.4.10.6. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/108335
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190515-sb-snmpdos
- http://www.securityfocus.com/bid/108335
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190515-sb-snmpdos
Get alerted when CVE-2019-1806 or the next vulnerability affects your stack