What’s Vulnerable › Vulnerabilities
CVE-2019-18224
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-10-21 · updated 2026-10-14
- Weakness: CWE-787
Description
idn2_to_ascii_4i in lib/lookup.c in GNU libidn2 before 2.1.1 has a heap-based buffer overflow via a long domain string.
Affected products
- GNU Libidn2: before 2.1.1 — fixed in 2.1.1
How to fix
Upgrade to a fixed version: GNU Libidn2 2.1.1. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-12/msg00008.html
- http://lists.opensuse.org/opensuse-security-announce/2019-12/msg00009.html
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=12420
- https://github.com/libidn/libidn2/commit/e4d1558aa2c1c04a05066ee8600f37603890ba8c
- https://github.com/libidn/libidn2/compare/libidn2-2.1.0...libidn2-2.1.1
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/JDQVQ2XPV5BTZUFINT7AFJSKNNBVURNJ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MINU5RKDFE6TKAFY5DRFN3WSFDS4DYVS/
- https://seclists.org/bugtraq/2020/Feb/4
- https://security.gentoo.org/glsa/202003-63
- https://usn.ubuntu.com/4168-1/
- https://www.debian.org/security/2020/dsa-4613
- http://lists.opensuse.org/opensuse-security-announce/2019-12/msg00008.html
Get alerted when CVE-2019-18224 or the next vulnerability affects your stack