What’s Vulnerable › Vulnerabilities
CVE-2019-1825: Cisco Prime Infrastructure and Evolved Programmable Network Manager SQL Injection Vulnerabilities
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-05-16 · updated 2026-06-17
- Weakness: CWE-89
Description
A vulnerability in the web-based management interface of Cisco Prime Infrastructure (PI) and Cisco Evolved Programmable Network (EPN) Manager could allow an authenticated, remote attacker to execute arbitrary SQL queries. This vulnerability exist because the software improperly validates user-supplied input in SQL queries. An attacker could exploit this vulnerability by sending a crafted HTTP request that contains malicious SQL statements to the affected application. A successful exploit could allow the attacker to view or modify entries in some database tables, affecting the integrity of the data.
Affected products
- Cisco Evolved Programmable Network Manager (EPNM): before 3.0.1 — fixed in 3.0.1
- Cisco Network Level Service: 3.0(0.0.83b)
- Cisco Prime Infrastructure: before 3.4.1 — fixed in 3.4.1
How to fix
Upgrade to a fixed version: Cisco Evolved Programmable Network Manager (EPNM) 3.0.1; Cisco Prime Infrastructure 3.4.1. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/108337
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190515-pi-sqlinject
- http://www.securityfocus.com/bid/108337
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190515-pi-sqlinject
Get alerted when CVE-2019-1825 or the next vulnerability affects your stack