What’s Vulnerable › Vulnerabilities
CVE-2019-18277
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 10.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-10-23 · updated 2026-06-17
- Weakness: CWE-444
Description
A flaw was found in HAProxy before 2.0.6. In legacy mode, messages featuring a transfer-encoding header missing the "chunked" value were not being correctly rejected. The impact was limited but if combined with the "http-reuse always" setting, it could be used to help construct an HTTP request smuggling attack against a vulnerable component employing a lenient parser that would ignore the content-length header as soon as it saw a transfer-encoding one (even if not entirely valid according to the specification).
Affected products
- HAProxy: before 2.0.6 — fixed in 2.0.6
How to fix
Upgrade to a fixed version: HAProxy 2.0.6. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-12/msg00016.html
- http://lists.opensuse.org/opensuse-security-announce/2019-12/msg00019.html
- https://git.haproxy.org/?p=haproxy-2.0.git%3Ba=commit%3Bh=196a7df44d8129d1adc795da020b722614d6a581
- https://lists.debian.org/debian-lts-announce/2022/05/msg00045.html
- https://nathandavison.com/blog/haproxy-http-request-smuggling
- https://usn.ubuntu.com/4174-1/
- https://www.mail-archive.com/haproxy%40formilux.org/msg34926.html
- http://lists.opensuse.org/opensuse-security-announce/2019-12/msg00016.html
- http://lists.opensuse.org/opensuse-security-announce/2019-12/msg00019.html
- https://git.haproxy.org/?p=haproxy-2.0.git%3Ba=commit%3Bh=196a7df44d8129d1adc795da020b722614d6a581
- https://lists.debian.org/debian-lts-announce/2022/05/msg00045.html
- https://nathandavison.com/blog/haproxy-http-request-smuggling
Get alerted when CVE-2019-18277 or the next vulnerability affects your stack