What’s Vulnerable › Vulnerabilities
CVE-2019-1829: Cisco Aironet Series Access Points Command Injection Vulnerability
- Severity: medium (CVSS 6.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-18 · updated 2026-06-17
- Weakness: CWE-16
Description
A vulnerability in the CLI of Cisco Aironet Series Access Points (APs) could allow an authenticated, local attacker to gain access to the underlying Linux operating system (OS) without the proper authentication. The attacker would need valid administrator device credentials. The vulnerability is due to improper validation of user-supplied input for certain CLI commands. An attacker could exploit this vulnerability by authenticating to an affected device and submitting crafted input for a CLI command. A successful exploit could allow the attacker to obtain access to the underlying Linux OS without proper authentication.
Affected products
- Cisco Aironet Access Point Software: before 8.3.150.0; from 8.5 before 8.5.140.0; from 8.6.101.0 before 8.8.111.0; 8.5(131.0) — fixed in 8.3.150.0, 8.5.140.0, 8.8.111.0
How to fix
Upgrade to a fixed version: Cisco Aironet Access Point Software 8.3.150.0, 8.5.140.0, 8.8.111.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/107990
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190417-air-ap-cmdinj
- http://www.securityfocus.com/bid/107990
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190417-air-ap-cmdinj
Get alerted when CVE-2019-1829 or the next vulnerability affects your stack