What’s Vulnerable › Vulnerabilities
CVE-2019-18408
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-24 · updated 2026-06-17
- Weakness: CWE-416
Description
archive_read_format_rar_read_data in archive_read_support_format_rar.c in libarchive before 3.4.0 has a use-after-free in a certain ARCHIVE_FAILED situation, related to Ppmd7_DecodeSymbol.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 19.04
- Debian Linux: 8.0
- libarchive: before 3.4.0 — fixed in 3.4.0
How to fix
Upgrade to a fixed version: libarchive 3.4.0. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-12/msg00012.html
- http://lists.opensuse.org/opensuse-security-announce/2019-12/msg00015.html
- https://access.redhat.com/errata/RHSA-2020:0203
- https://access.redhat.com/errata/RHSA-2020:0246
- https://access.redhat.com/errata/RHSA-2020:0271
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=14689
- https://github.com/libarchive/libarchive/commit/b8592ecba2f9e451e1f5cb7ab6dcee8b8e7b3f60
- https://github.com/libarchive/libarchive/compare/v3.3.3...v3.4.0
- https://lists.debian.org/debian-lts-announce/2019/10/msg00034.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6LZ4VJGTCYEJSDLOEWUUFG6TM4SUPFSY/
- https://seclists.org/bugtraq/2019/Nov/2
- https://security.gentoo.org/glsa/202003-28
Get alerted when CVE-2019-18408 or the next vulnerability affects your stack