What’s Vulnerable › Vulnerabilities
CVE-2019-18574
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-03 · updated 2026-06-17
- Weakness: CWE-79
Description
RSA Authentication Manager software versions prior to 8.4 P8 contain a stored cross-site scripting vulnerability in the Security Console. A malicious Security Console administrator could exploit this vulnerability to store arbitrary HTML or JavaScript code through the web interface which could then be included in a report. When other Security Console administrators open the affected report, the injected scripts could potentially be executed in their browser.
Affected products
- Dell RSA Authentication Manager: 8.4, 8.4-p1, 8.4-p2, 8.4-p3, 8.4-p4, 8.4-p5 (+2)
- Dell EMC RSA Authentication Manager Security Console, Operation Console and Self-Service Console: before 8.4 — fixed in 8.4
How to fix
Upgrade to a fixed version: Dell EMC RSA Authentication Manager Security Console, Operation Console and Self-Service Console 8.4. Check the vendor advisory for mitigations.
References
- https://www.dell.com/support/security/en-us/details/DOC-109297/DSA-2019-168-RSA®%3B-Authentication-Manager-Software-Stored-Cross-Site-Scripting-Vulnerability
- https://www.dell.com/support/security/en-us/details/DOC-109297/DSA-2019-168-RSA®%3B-Authentication-Manager-Software-Stored-Cross-Site-Scripting-Vulnerability
Get alerted when CVE-2019-18574 or the next vulnerability affects your stack