What’s Vulnerable › Vulnerabilities
CVE-2019-18578
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-03-13 · updated 2026-06-17
- Weakness: CWE-79
Description
Dell EMC XtremIO XMS versions prior to 6.3.0 contain a stored cross-site scripting vulnerability. A low-privileged malicious remote user of XtremIO may exploit this vulnerability to store malicious HTML or JavaScript code in application fields. When victim users access the injected page through their browsers, the malicious code may be executed by the web browser in the context of the vulnerable web application.
Affected products
- Dell XtremIO: before 6.3.0 — fixed in 6.3.0
How to fix
Upgrade to a fixed version: Dell XtremIO 6.3.0. Check the vendor advisory for mitigations.
References
- https://www.dell.com/support/security/en-us/details/539703/DSA-2019-172-Dell-EMC-XtremIO-Security-Update-for-Multiple-Vulnerabilities
- https://www.dell.com/support/security/en-us/details/539703/DSA-2019-172-Dell-EMC-XtremIO-Security-Update-for-Multiple-Vulnerabilities
Get alerted when CVE-2019-18578 or the next vulnerability affects your stack