What’s Vulnerable › Vulnerabilities
CVE-2019-18588
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-10 · updated 2026-06-17
- Weakness: CWE-79
Description
Dell EMC Unisphere for PowerMax versions prior to 9.1.0.9, Dell EMC Unisphere for PowerMax versions prior to 9.0.2.16, and Dell EMC PowerMax OS 5978.221.221 and 5978.479.479 contain a Cross-Site Scripting (XSS) vulnerability. An authenticated malicious user may potentially exploit this vulnerability to inject javascript code and affect other authenticated users' sessions.
Affected products
- Dell Emc Powermax: 5978.221.221, 5978.479.479
- Dell Emc Unisphere For Powermax: before 9.0.2.16; from 9.1.0.0 before 9.1.0.9 — fixed in 9.0.2.16, 9.1.0.9
How to fix
Upgrade to a fixed version: Dell Emc Unisphere For Powermax 9.0.2.16, 9.1.0.9. Check the vendor advisory for mitigations.
References
- https://www.dell.com/support/security/en-us/details/539808/DSA-2019-193-Dell-EMC-Unisphere-for-PowerMax-and-Dell-EMC-PowerMax-Embedded-Management-Cross-Site
- https://www.dell.com/support/security/en-us/details/539808/DSA-2019-193-Dell-EMC-Unisphere-for-PowerMax-and-Dell-EMC-PowerMax-Embedded-Management-Cross-Site
Get alerted when CVE-2019-18588 or the next vulnerability affects your stack