What’s Vulnerable › Vulnerabilities
CVE-2019-18609
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-01 · updated 2026-06-17
- Weakness: CWE-787
Description
An issue was discovered in amqp_handle_input in amqp_connection.c in rabbitmq-c 0.9.0. There is an integer overflow that leads to heap memory corruption in the handling of CONNECTION_STATE_HEADER. A rogue server could return a malicious frame header that leads to a smaller target_size value than needed. This condition is then carried on to a memcpy function that copies too much data into a heap buffer.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 19.04, 19.10
- Debian Linux: 8.0
- Fedoraproject Fedora: 30, 31
- Rabbitmq-C Project Rabbitmq-C: before 0.10.0 — fixed in 0.10.0
How to fix
Upgrade to a fixed version: Rabbitmq-C Project Rabbitmq-C 0.10.0. Check the vendor advisory for mitigations.
References
- https://github.com/alanxz/rabbitmq-c/blob/master/ChangeLog.md
- https://github.com/alanxz/rabbitmq-c/commit/fc85be7123050b91b054e45b91c78d3241a5047a
- https://lists.debian.org/debian-lts-announce/2019/12/msg00004.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/WA7CPNVYMF6OQNIYNLWUY6U2GTKFOKH3/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/XQER6XTKYMHNQR7QTHW7DJAH645WQROU/
- https://news.ycombinator.com/item?id=21681976
- https://security.gentoo.org/glsa/202003-07
- https://usn.ubuntu.com/4214-1/
- https://usn.ubuntu.com/4214-2/
- https://github.com/alanxz/rabbitmq-c/blob/master/ChangeLog.md
- https://github.com/alanxz/rabbitmq-c/commit/fc85be7123050b91b054e45b91c78d3241a5047a
- https://lists.debian.org/debian-lts-announce/2019/12/msg00004.html
Get alerted when CVE-2019-18609 or the next vulnerability affects your stack