What’s Vulnerable › Vulnerabilities
CVE-2019-18610
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 50.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-22 · updated 2026-06-17
- Weakness: CWE-862
Description
An issue was discovered in manager.c in Sangoma Asterisk through 13.x, 16.x, 17.x and Certified Asterisk 13.21 through 13.21-cert4. A remote authenticated Asterisk Manager Interface (AMI) user without system authorization could use a specially crafted Originate AMI request to execute arbitrary system commands.
Affected products
- Debian Linux: 8.0, 9.0
- Digium Asterisk: from 13.0.0 before 13.29.2; from 16.0.0 before 16.6.2; from 17.0.0 before 17.0.1 — fixed in 13.29.2, 16.6.2, 17.0.1
- Digium Certified Asterisk: 13.21.0, 13.21.0-cert1, 13.21.0-cert2, 13.21.0-cert3, 13.21.0-cert4, 13.21.0-rc1
How to fix
Upgrade to a fixed version: Digium Asterisk 13.29.2, 16.6.2, 17.0.1. Check the vendor advisory for mitigations.
References
- http://downloads.asterisk.org/pub/security/AST-2019-007.html
- https://lists.debian.org/debian-lts-announce/2019/11/msg00038.html
- https://lists.debian.org/debian-lts-announce/2022/04/msg00001.html
- https://www.asterisk.org/downloads/security-advisories
- http://downloads.asterisk.org/pub/security/AST-2019-007.html
- https://lists.debian.org/debian-lts-announce/2019/11/msg00038.html
- https://lists.debian.org/debian-lts-announce/2022/04/msg00001.html
- https://www.asterisk.org/downloads/security-advisories
Get alerted when CVE-2019-18610 or the next vulnerability affects your stack