What’s Vulnerable › Vulnerabilities
CVE-2019-18622
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-22 · updated 2026-06-17
- Weakness: CWE-89
Description
An issue was discovered in phpMyAdmin before 4.9.2. A crafted database/table name can be used to trigger a SQL injection attack through the designer feature.
Affected products
- Fedoraproject Fedora: 30, 31
- openSUSE Backports Sle: 15.0, 15.0-sp1
- openSUSE Leap: 15.0, 15.1
- phpMyAdmin: before 4.9.2 — fixed in 4.9.2
How to fix
Upgrade to a fixed version: phpMyAdmin 4.9.2. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-12/msg00002.html
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00024.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/BA4DGF7KTQS6WA2DRNJSW66L43WB7LRV/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/W5GW4KEMNCBQYZCIXEJYC42OEBBN2NSH/
- https://security.gentoo.org/glsa/202003-39
- https://www.phpmyadmin.net/security/PMASA-2019-5/
- http://lists.opensuse.org/opensuse-security-announce/2019-12/msg00002.html
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00024.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/BA4DGF7KTQS6WA2DRNJSW66L43WB7LRV/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/W5GW4KEMNCBQYZCIXEJYC42OEBBN2NSH/
- https://security.gentoo.org/glsa/202003-39
- https://www.phpmyadmin.net/security/PMASA-2019-5/
Get alerted when CVE-2019-18622 or the next vulnerability affects your stack