What’s Vulnerable › Vulnerabilities
CVE-2019-1865: Cisco Integrated Management Controller Command Injection Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-21 · updated 2026-06-17
- Weakness: CWE-78
Description
A vulnerability in the web-based management interface of Cisco Integrated Management Controller (IMC) Software could allow an authenticated, remote attacker to inject arbitrary commands that are executed with root privileges on an affected device. The vulnerability is due to insufficient validation of user-supplied input by the affected software. An attacker could exploit this vulnerability by invoking an interface monitoring mechanism with a crafted argument on the affected software. A successful exploit could allow the attacker to inject and execute arbitrary, system-level commands with root privileges on an affected device.
Affected products
- Cisco Integrated Management Controller: from 1.5.0.0 before 1.5\(9g\); from 2.0.0.0 before 2.0\(13o\); from 3.0.0.0 before 3.0\(4k\); from 4.0.0.0 before 4.0\(4b\); from 4.0.0.0 before 4.0\(1d\); from 4.0.0.0 before 4.0\(2c\) — fixed in 1.5\(9g\), 2.0\(13o\), 3.0\(4k\), 4.0\(1d\), 4.0\(2c\), 4.0\(4b\)
- Cisco Unified Computing System (Managed): 4.0(1c)hs3
How to fix
Upgrade to a fixed version: Cisco Integrated Management Controller 1.5\(9g\), 2.0\(13o\), 3.0\(4k\), 4.0\(1d\). Check the vendor advisory for mitigations.
References
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190821-imc-cmdinj-1865
- https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20190821-imc-cmdinj-1865
Get alerted when CVE-2019-1865 or the next vulnerability affects your stack